Security Fraud


The MOD you are using maybe needs a security update.

In order to deliver the best quality for our VIPs we maybe stopped the support for the currently used APK.

The error can show up too if you use a bad internet connection. So please try first with a better connection to see if the error still show up.

For the case we really crash a APK you will see that we uploaded a "security update". If you didn't see this note in the update history it is just your connection.

If you see this message + we uploaded a security update + you are a legit VIP on www.platinmods.com, please re-download the updated APK in the VIP area.

All you need to do is to update the MOD with the new APK and get back to your game.